Tinection ·

Tint主题授权相关说明

2017/1/18更新增加ZendGurad加密

为了适配更多的主机环境,目前新增了ZendGuard加密授权的版本,适用于PHP5.3和PHP5.4的环境,一些默认包含了Zend Guard Loader的虚拟主机如万网主机等可以直接使用Tint主题了。


目前Tint主题的核心源码采用了PHP动态扩展加密解密,在发布的一定周期内将维持这种模式,包括我个人的服务器均采用了这种源码保护方式,以保障主题域名授权模式的可行性。

选择扩展版本

用户在付费购买【立即购买】主题并交易成功之后,可在多处查看主题下载链接等付费内容和信息。

  • Tint主题的购买页付费内容选项卡

  • 个人中心订单详情页面

 

可以看见主题的打包是针对特定PHP版本的,因为编译的PHP动态扩展是指定PHP版本的,加密后的内容则不一致。请选择与你的服务器运行的PHP版本一致的主题包使用。

解压选定的主题包,其中包含了一个loader5.4.so|loader5.5.so|loader5.6.so|loader7.0.so|loader7.1.so等名称的文件,即为Tint使用的PHP动态加解密扩展,扩展名包含的数字指明对应的PHP版本号。复制该动态扩展文件至服务器文件系统任意路径,推荐较短的路径或者不复制直接使用主题路径下的扩展文件。

加载扩展到PHP

找到你的php.ini等PHP配置文件,LNMP一键安装包一般在/usr/local/bin/php/etc/php.ini,使用AMH面板的一般在网站文件夹下的etc文件夹内,如果你不确定可以通过phpinfo信息查看当前应用的PHP配置文件路径。

编辑php.ini等配置文件,在文件结尾加入下面2行:

保存配置文件的修改,重启PHP。使用LNMP的可以使用命令/etc/init.d/php-fpm restart重启,使用AMH面板的请在面板中重启。

完成重启后,请访问phpinfo文件查看PHP的信息,并查找关键字php_screw,如果找到记录则表明扩展加载成功了。

加载不成功处理

由于PHP版本众多,即便同一个子版本仍有多个发行版,PHP API数据均可能不同,你需要联系我手动为你编译正确对应你服务器PHP版本的扩展以及提供新的加密代码。在此,推荐使用PHP7.0以上版本,本站使用LNMP1.3一键安装包并安装时选择了PHP7(完整的版本号7.0.7),如果你加载扩展失败也可以通过重装WEB环境来解决。

域名授权

以上步骤完成后,请访问WebApproach产品授权中心,提供购买Tint主题交易成功的订单号以及顶级域名等必要信息以申请域名授权。

授权成功后会获得一个授权码,请同时编辑主题主目录functions.php,将订单号和授权码填入相应位置,完成最终授权。

目前Tint可绑定两个顶级域名,首次你可以按上述流程自主绑定,若要增加第二个域名,请联系管理员添加。

扩展加载失败解决方案

目前扩展加载失败大部分原因是系统的Glibc版本不符合扩展的要求。主题加密授权使用的扩展要求Glibc2.14版本,而CentOS6.5等默认是2.12的。请参考https://webapproach.net/glibc2-14-installation.html升级你的Glibc。

如果仍然加载失败,请联系管理员。

WordPress新主题Tint Pro版[更新至2.6.0]

299.00
4.9 满分5 基于 29 个用户评分
立即购买

参与评论